Gelöst: WordPress-Plugin ‘The newsletter Plugin’ mit Internal Server Error 500

Sobald ich ‘Neuer Newsletter’ klicke kommt folgende Fehlermeldung:

500 – Interner Serverfehler.

Problem bei der gesuchten Ressource. Sie kann nicht angezeigt werden.

 

http://www.thenewsletterplugin.com/forums/topic/internal-server-error-500#post-30994

Workaround:
temporarily activate debug mode in wp-config.php with:
define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Da auch dieser Trick inzwischen (Stand: 15.Mai 2017) nicht mehr funktioniert, habe ich auf Newsletter 4.9.0 geupdated – ohne Erfolg. Auch habe ich WordPress selbst auf die aktuelle 4.7.4 geupdated – ohne Erfolg. Auch habe ich mal alle(!) Plugins temporär deaktiviert – ohne Erfolg.

Also hab ich mir doch mal das debug.log angeschaut, wo noch ein paar ältere Warnings zum Newsletter-Plugin zu finden waren – immerhin eine Spur:

[15-Apr-2017 15:28:34 UTC] PHP Warning: is_file(): open_basedir restriction in effect. File(C:\Inetpub\vhosts\wvps83-169-10-28.dedicated.hosteurope.de\site5/wp-content/plugins/newsletter/emails/themes/composer.gif/theme.php) is not within the allowed path(s): (C:/Inetpub/vhosts/wvps83-169-10-28.dedicated.hosteurope.de\;C:\Windows\Temp\) in C:\Inetpub\vhosts\wvps83-169-10-28.dedicated.hosteurope.de\site5\wp-content\plugins\newsletter\includes\themes.php on line 114

Nach dem Umzug von meinem Windows-Server auf einen Unix-Server hat sich dieses Problem aufgelöst. Irgendwie kam das Plugin nicht mit der Pfadschreibweise auf Windows zurecht.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.